Shop by Category | Brand | Order Tracking | Customer Care | Contact Us | Wishlist | My Account |
  • All Departments
  • Digital Download
My Drafts
General Topics
  Tech News
  What's New Q&A
  Important Notices
  General Discussions
  Site Bug Reports
  PC Builder Workshop
  NCIX Gaming Community
  NCIX Tech Tips
  Linus Tech Tips
  NCIX Esther
  Off Topic
  Product Requests
  PC Modding
  Manufacturer Support
  Power Supplies
  Folding @ Home
Software Topics
  Operating Systems
  Open Source Projects
  Driver Updates
Broadband Topics
  Shaw Cable
  Telus ADSL
  Speed Test Reports
  Hardware FAQs
  Overclocking FAQs
  Other FAQs
  Software FAQs
Top Categories
  Blu-Ray Drives
  Bundle Deals
  CD & DVD Drives
  Computer Cases
  CPU Heatsinks
  DDR2 Desktop Memory
  DDR3 Desktop Memory
  Digital Cameras
  External Hard Drives
  Fans & Cooling
  Hard Drives
  HTPC Accessories
  Inkjet Printers
  Internet Routers
  Laser Printers
  LCD Monitors
  Mice & Pointing Devices
  Mobile Phones
  Multifunction Printers
  Network Adapters
  Network Storage NAS
  Network Switches
  PC Games
  PlayStation 3 Games
  Power Management
  Power Supplies
  Processors (CPUs)
  SD Secure Digital
  Solid State Drives - SSD
  Speakers & Audio
  USB Flash Drives
  Video Cards
  Wireless Accessories
  XBox 360
Subject: Networking Questions/Confirmation
Share this:  
Author Date Posted Tools
TheWhite Dec 22, 2012 06:11 PM Reply | Bookmark
Like | Top | Bottom

Hey Network Guru's I just have a quick question that I think I might have answered but, I wan't to confirm my findings with the people that have far more experience then I.

I'm currently running a network in my home, I have the Bell Gateway (Turned wireless off) and I'm using a Linksys Router with DD-WRT on it. I also have a Switch in my basement.

My problem is this, I can't ping anything on the other side of the switch from anything connected to the router with DD-WRT. My first thought was I set something up incorrectly in DD-WRT, as all the devices still share the same prefix for the IPs 192.168.X.XXX

But through trial and error, I think the problem is the subnet. My Thinking (and this is where I need confirmation) is that even though they are looking at the same IP, because I have an unmanaged switch in the basement, This is causing those devices to be on a different subnet.

The reason this came up is because I'm trying to fix a streaming issue that is driving me nuts, PSM while running on my server can't see my other computers or my Xbox/PS3. But, I can still access the server through RDC and share the drives. (The Xbox/PS2 is behind the switch along with the server, if that makes a difference)

So, (again confirmation please) the only way to fix this would be to purchase another router, and then bridge it with the DD-WRT to allow all the devices to work on the same subnet? Is my thinking correct here? Was a lead astray with a switch, and the months of headaches could have been averted by just using another router? Is there a setting that I'm missing that could fix this? Any help/direction/Confirmation would be great!


Topic URL:

Tip Posting | My Postings (671) | My Reviews (16) | View Source
Featherawr Dec 22, 2012 07:42 PM Reply | Bookmark
Like | Top | Bottom

Is PSM only a LAN thing? Also what doesn't quite make sense to me is why the pings fail yet RDC is fine?

One thing you should be aware of though for the subnet is that the (/24) subnet mask you'll be using (it's used w/ 192.168.x.x) uses the first three octets as the network portion and the fourth as the host so if you're using the network for example, all the devices on that LAN need to stay within the - range for your devices.

This message was modified by the poster at 12 22, 2012 08:06 PM

Tip Posting | My Postings (384) | My Reviews (13) | View Source
Hyperlight Dec 22, 2012 07:42 PM Reply | Bookmark
Like | Top | Bottom

Let me guess, you have plugged your the WAN port of your linksys router into the switch. If so you have firewalled and NATed a section of your internal network.

What you want to do, is turn of DHCP on your linksys, and plug your switch into a LAN port on your linksys.

Tip Posting | My Postings (12904) | My Reviews (8) | View Source
TheWhite Dec 22, 2012 08:25 PM Reply | Bookmark
Like | Top | Bottom

Hey Hyperlight, that's what I was confused about as well (RDC Vs PSM)

I checked my set up again, and I currently have it set with the Following

Bell Gateway LANWAN (Port 4) -> Linksys Internet port -> Then Port 3 On the Linksys -> to the D-Link Switch Port 1

My computer, along with the computer I could ping are both connected directly to the linksys.

The Server, and both my PS3, and 360 are connected via ports on the D-Link Switch.

All computers are on the 192.168.1.XXX Ip group, and all using the subnet 255

So maybe I did muck something up...hhhhmmmm


Tip Posting | My Postings (671) | My Reviews (16) | View Source
Tsu Dec 22, 2012 09:21 PM Reply | Bookmark
Like (1) | Top | Bottom

I'm sorry, but curiosity is killing me.. What does PSM mean? At first, I thought it was Playstation Media Server... then Plex Media Server, since it was related to streaming... But then, wouldn't that be PMS?

Tip Posting | My Postings (42) | My Reviews (30) | View Source
TheWhite Dec 23, 2012 05:53 AM Reply | Bookmark
Like (1) | Top | Bottom

LOL Tsu! PS3 Media Server. It detects WMP on the local server but nothing outside of it.

Tip Posting | My Postings (671) | My Reviews (16) | View Source
SixDs Dec 23, 2012 08:53 AM Reply | Bookmark
Like | Top | Bottom

I am still a little confused about the topology here. Firstly, what Bell gateway do you have? I assume that is connected to your phone lines and is actually your internet gateway? Most of these units have custom firmware and cannot be used in bridge mode, so you must have DHCP turned off on the linksys and are using it in bridge mode? If not, you need to do this as Hyperlight says, since there can be only one DHCP server on the network, and, unfortunately, that must be the Bell unit.

Tip Posting | My Postings (3651) | My Reviews (86) | View Source
Tsu Dec 23, 2012 08:53 AM Reply | Bookmark
Like | Top | Bottom

Ah, my first guess was right then!

Anyway, have you tried using Serviio or Plex Media Server? I'm not sure what exactly PS3 Media Server does, but if you only use it for streaming videos from your server, then I'd give at least those two a try. (I've already used both, but ended up sticking with Plex since I have a roku. My PS3 could also stream from it.)

If it works, the problem might lie in the PS3 Media Server.

Tip Posting | My Postings (42) | My Reviews (30) | View Source
TheWhite Dec 23, 2012 09:11 AM Reply | Bookmark
Like (1) | Top | Bottom

SixD's you many be correct! I though I had the bell gateway turned into a bridge mode, but maybe I just deactivated the wireless portion in favour of the Linksys...I didn't even think about that. I have the Gigaset SE567, looking at the settings I have DHCP Range: thru reported from the Gateway, and DHCP ServerEnabled from my DDWRT, so I should remove the DHCP systems in the Linksys and let the Bell gateway control that? I can't seem to find away to stop bell from controlling the DHCP.

Tip Posting | My Postings (671) | My Reviews (16) | View Source
TheWhite Dec 23, 2012 12:13 PM Reply | Bookmark
Like | Top | Bottom

Thanks SixDs, I went ahead and confirmed that the Bell Aliant Gateway/modem is controlling the DHCP. So I went into the settings of the linksys router and changed it so that, My internet connection is "Automatic Configuration - DHCP"
I then went and "Disabled" the DHCP Server settings.

I can not successfully ping my server from this computer which I couldn't before.

But, I'm now having an issue with the Xbox 360 on my network. It won't connect to the internet when I first open the internet settings it is assigned an IP address,, but won't connect to the network, when I run a check it fails and the IP address defaults back to a 169.

Grrr, I don't know how you networking people work with this, I'm sure I'm doing something really stupid but its starting to get really annoying lol.

All I want is to have all my systems on the network and able to share/stream from each hard to ask for!

Tip Posting | My Postings (671) | My Reviews (16) | View Source
SixDs Dec 24, 2012 03:03 AM Reply | Bookmark
Like | Top | Bottom

OK, so everything is working now except the Xbox? Did you originally manually set the Xbox IP address to In other words, it was assigned a fixed IP address? If so, the problem might lie in the default gateway address. The Bell gateway should be using a standard address of The Linksys (which the Xbox was originally recognizing as the default gateway, since DHCP was turned on) may have been using another IP address.

Do this: go on one of your computers and run ipconfig. This will show the IP address of that PC, the subnet mask and the default gateway (which should be the Bell unit). Record the gateway IP, then check the settings on the Xbox to ensure that they are using the correct default gateway address. Reset them if necessary.

Good luck, and Happy Holidays!

Tip Posting | My Postings (3651) | My Reviews (86) | View Source
john m Dec 24, 2012 05:11 AM Reply | Bookmark
Like | Top | Bottom

I am also want information about that. If you have a information about that then please help me.

Tip Posting | My Postings () | My Reviews () | View Source
Prismline Dec 24, 2012 09:21 AM Reply | Bookmark
Like | Top | Bottom

You turned off the DHCP on the Linksys router, but because it isn't in bridge mode, your internal devices won't get an IP address from the Bell router/modem.

The Bell Gateway is acting as a router and set up as DHCP server on LAN ports giving out addresses thru

You have the Linksys DD-WRT router connected as you stated above, but you need to configure it properly.

You have 3 choices with the devices that you have:

1) Remove the Linksys router and hook the switch up to a LAN port on the Bell router/modem. Now all of your internal devices should get addresses. Hook up the Linksys router WAN port to the switch and use it as just an access point (nothing connected to LAN ports).

2) Set the Linksys router into bridge mode (can't remember how to do that or whether it's even possible) so it's interfaces don't IP addresses. Hook up the WAN port of of Linksys router to a Bell gateway LAN port. Hook up one of the LAN ports to your switch. All of your computers/PS3 should now get a address.

3) Connect the WAN port of Linksys router to LAN port of Bell router/modem. Set to automatic (DHCP) for WAN interface. It should get a address. Turn on DHCP server on Linksys router and it will give out addresses to your computer and other devices. Plug the switch into a LAN port on the Linksys router. (This is the least desirable option as it does a double-NAT. The Linksys translates addresses from to and then the Bell router/modem translates them again to the public IP address.)

This message was modified by the poster at 12 24, 2012 09:30 AM

Tip Posting | My Postings (380) | My Reviews (2) | View Source
TheWhite Dec 24, 2012 09:44 AM Reply | Bookmark
Like | Top | Bottom

Thanks SixD, I'll go ahead and check that when I get a chance. I also took the step to calling Bell again today, and finally got someone that agreed to send me a modem only device, so that I don't have to use the gateway any more. Hoping that makes it easier in the long run to organize things. They are sending me a SpeedStream 4200, not sure if its going to be any can't be any worse :P LOL

Tip Posting | My Postings (671) | My Reviews (16) | View Source
TheWhite Dec 24, 2012 10:10 AM Reply | Bookmark
Like | Top | Bottom

w Prismline, option 1 in your list is...interesting. Honestly I didn't even think about do that, I think because I got the switch after I had the router. This almost seems like a really simple way to fix the problem.

The D-link switch I have has 8 ports on the back, more then enough for everything I need. My 1 questions would be, if I then hook the Linksys up to the Switch (The other way, so its at the end) and don't hook anything to its LANs, would the router ONLY be good for wireless on the network? IE it wouldn't see the server..ect?

Would I have to change any settings on the router to accomplish any of these changes or would it be a plug an go? At this point with a new modem coming I genuinely interested in learning how I can better approach these things in the futures.

Thanks all for the help!

Tip Posting | My Postings (671) | My Reviews (16) | View Source
SixDs Dec 24, 2012 07:43 PM Reply | Bookmark
Like | Top | Bottom

The Speedstream should work fine. I used one ahead of my router for many years without issue.

Tip Posting | My Postings (3651) | My Reviews (86) | View Source

Call Queue
Now Serving
Avg. Response Time
Estimate: 17 mins
Request Call Back
(Web Orders Only)

Recent Experts
1. Greg * (34384)
2. Saberon (16499)
3. Cannon Fodder (8762)
4. Hotshot (6376)
5. Entz (4607)
All Time Experts
1. Mr. Friendly™ (51387)
2. The Wizard (39824)
3. death_hawk™ (35144)
4. Not An Expert (26343)
5. Lance W (25246)
Your Order Company Info Memberships Services Hotlinks
Order Status
RMAs (Merchandise returns)
Contact Us / Store Locator
Terms & Conditions
Privacy Policy
NCIX Rewards
Premier Partner Reseller Program
VIP Memberships
Advantage Membership
NCIX Affiliate Program
3rd Party Affiliate Program
Super Shipping Saver Club
Express Coverage
Express RMA
Express Shipping Service
Express Exchange and Care Coverage
Gift Cards & Balance Checker
Advanced Store Price Match
19th Anniversary Sale
Black Friday Sale 2015
Boxing Week Sale 2015
NCIX Newsletters
NCIX Forums
Folding @ Home Team
The Banner Vault
International Sites:  Canada
Copyright© 2015 Computer Inc. All rights reserved. S / Server ID:74 20150428125529  641 ms